const regex = /^\s*<\?php(?:.(?!\?>\s*$))*$/s;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*<\\?php(?:.(?!\\?>\\s*$))*$', 's')
const str = `<?php or whitespace<?php and NOT end with ?> or ?>
whitespace.?> `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}