#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)<h\d.+?(?=<h\d|$)"
Local $sString = "Aenean lacinia bibendum <a href="/life">life</a> sed consectetur. <a href="/work">Work</a> quis risus eget urna mollis ornare <a href="/about">about</a> leo." & @CRLF & _
"<h1> attribute="whatever">asiponfpweg ihnasegio</h1>asd" & @CRLF & _
"<p>whatever</p>" & @CRLF & _
"<img src=""></img>" & @CRLF & _
"<h3> attribute="whatever">asiponfpweg ihnasegio</h3>" & @CRLF & _
"<p>whatever</p>" & @CRLF & _
"<p>whatever</p>" & @CRLF & _
"<h1><span> attribute="whatever">asiponfpweg ihnasegio</span></h3>" & @CRLF & _
"<p>whatever</p>" & @CRLF & _
"<h3> attribute="whatever">asiponfpweg ihnasegio</h3>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")