# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<h\d.+?(?=<h\d|$)"
test_str = ("Aenean lacinia bibendum <a href=\"/life\">life</a> sed consectetur. <a href=\"/work\">Work</a> quis risus eget urna mollis ornare <a href=\"/about\">about</a> leo.\n"
"<h1> attribute=\"whatever\">asiponfpweg ihnasegio</h1>asd\n"
"<p>whatever</p>\n"
"<img src=\"\"></img>\n"
"<h3> attribute=\"whatever\">asiponfpweg ihnasegio</h3>\n"
"<p>whatever</p>\n"
"<p>whatever</p>\n"
"<h1><span> attribute=\"whatever\">asiponfpweg ihnasegio</span></h3>\n"
"<p>whatever</p>\n"
"<h3> attribute=\"whatever\">asiponfpweg ihnasegio</h3>")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.