#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)^\s*<\?php(?>.*\?>\s*$(*SKIP)(*F)|.*+$)"
Local $sString = "<?php or whitespace<?php and NOT end with ?> or ?>" & @CRLF & _
"whitespace.?> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")