$re = '/^\s*<\?php(?>.*\?>\s*$(*SKIP)(*F)|.*+$)/s';
$str = '<?php or whitespace<?php and NOT end with ?> or ?>
whitespace.?> ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);