#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?\K\|\|"
Local $sString = "|-" & @CRLF & _
"|Australia||3866||..||.." & @CRLF & _
"|-" & @CRLF & _
"|Austria||4528||4553||.." & @CRLF & _
"|-" & @CRLF & _
"|Belgium||4225||4256||.."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")