re = /^.*?\K\|\|/m
str = '|-
|Australia||3866||..||..
|-
|Austria||4528||4553||..
|-
|Belgium||4225||4256||..'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end