#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)(?:semlps/totalsource|sem-totalsource/2017)(?:/)?(?:.*[^0-9a-zA-Z].*)?(?:\\.aspx)?$"
Local $sString = "https://adp-iat.adp.com/sem-totalsource/2017/learnmorehro.aspx" & @CRLF & _
"" & @CRLF & _
"https://adp-iat.adp.com/sem-totalsource/2017/learnmorehro-ty.aspx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")