using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"~1|2|f~";
string input = @"1abc2efg";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}