package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`~1|2|f~`)
var str = `1abc2efg`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}