using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(word1|word2|word3))(?:.(?!\1))+?((?1))(?:.(?!\1)(?!\2))+?((?1))";
string input = @"a word3 word3 word2 word 3 word1 word2 word1";
RegexOptions options = RegexOptions.Multiline;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}