import Foundation
let pattern = #"(?=(word1|word2|word3))(?:.(?!\1))+?((?1))(?:.(?!\1)(?!\2))+?((?1))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"a word3 word3 word2 word 3 word1 word2 word1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}