package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\|([0-9]+)\)`)
var str = `A(1|1) B(1|3) C(1|6)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}