$re = '/\|([0-9]+)\)/m';
$str = 'A(1|1) B(1|3) C(1|6)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);