package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\d*(?:\.\d{1,3})?$`)
var str = `123.1234567890`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}