$re = '/^\d*(?:\.\d{1,3})?$/';
$str = '123.1234567890';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);