using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\d{4}|[a-zA-Z0-9]{1}[0-9]{1})([-][0-9]{1,5}))";
string input = @"C1-2015-13175";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}