package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([0-9]|[R])$`)
var str = `555f
3
sad22
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}