$re = '/^([0-9]|[R])$/m';
$str = '555f
3
sad22
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);