use strict;
my $str = '-81.82297519999997';
my $regex = qr/(-?\d+?\.\d{8})|.*/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";