$re = '/(-?\d+?\.\d{8})|.*/m';
$str = '-81.82297519999997';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;