$re = '/(?=(.*\n){3}Ethernet Interface)[\w\W]+(?=IfIndex)/';
$str = 'Tue Oct 0 00:00:00 UTC 0000
A:REDACTED# REDACTED 7/1/8
==============================================================
Ethernet Interface
===============================================================
Description : REDACTED
Interface : 0/0/0 Oper Speed : 10 Gbps
Link-level : Ethernet Config Speed : N/A
Admin State : up Oper Duplex : full
Oper State : up Config Duplex : N/A
Physical Link : Yes MTU : 2004
Single Fiber Mode : No Min Frame Length : 64 Bytes
IfIndex : REDACTED Hold time up : 90 seconds';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);