# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(.*\n){3}Ethernet Interface)[\w\W]+(?=IfIndex)"
test_str = ("Tue Oct 0 00:00:00 UTC 0000\n"
"A:REDACTED# REDACTED 7/1/8 \n\n"
"==============================================================\n"
"Ethernet Interface\n"
"===============================================================\n"
"Description : REDACTED\n"
"Interface : 0/0/0 Oper Speed : 10 Gbps\n"
"Link-level : Ethernet Config Speed : N/A\n"
"Admin State : up Oper Duplex : full\n"
"Oper State : up Config Duplex : N/A\n"
"Physical Link : Yes MTU : 2004\n"
"Single Fiber Mode : No Min Frame Length : 64 Bytes\n"
"IfIndex : REDACTED Hold time up : 90 seconds")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.