$re = '/(?<=This is)(.*)(?=sentence)/s';
$str = 'This is my first sentence. This is my second sentence.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);