re = /(?<=This is)(.*)(?=sentence)/
str = 'This is my first sentence. This is my second sentence.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end