package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)\[[^{].*[^}]\]|\[\{.*\}\]`)
var str = `[anything can be here]
[{anything can be here}]
[anything can be here}]
[{anything can be here]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}