re = /\[[^{].*[^}]\]|\[\{.*\}\]/mi
str = '[anything can be here]
[{anything can be here}]
[anything can be here}]
[{anything can be here]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end