package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b(?P<first>\d+)\.(?P<second>(?P=first))\b`)
var str = `123.456
123.123
123.1234`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}