re = /\b(?P<first>\d+)\.(?P<second>(?P=first))\b/m
str = '123.456
123.123
123.1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end