const regex = /(?= \d|\D+$|(?<!\D) )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?= \\d|\\D+$|(?<!\\D) )', 'gm')
const str = `Some Street 59A
Some Street 59-69
Some Street 1.1
6' Street 45b
6' Some street 324/326 A/1
Some Street 65 A/1
42th Stack ave. 59-69`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}