use strict;
my $str = 'Some Street 59A
Some Street 59-69
Some Street 1.1
6\' Street 45b
6\' Some street 324/326 A/1
Some Street 65 A/1
42th Stack ave. 59-69';
my $regex = qr/(?= \d|\D+$|(?<!\D) )/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}