package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^\d-.]+`)
var str = `a=<-1.9,.2,-3> b=<4,-5.8,6>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}