$re = '/[^\d-.]+/';
$str = 'a=<-1.9,.2,-3> b=<4,-5.8,6>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);