import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^:]+):|(?!^)(?<=\\G)(?:\\s)([^,]+)(?:,|$)";
final String string = "Prompt: professional digital [airbrush:gouache:0.6] art of 20 year old (mythical:1.1) demon with long black hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy country background, rule of thirds, composed\n"
+ "Negative prompt: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned\n"
+ "Template: professional digital [airbrush:gouache:0.6] art of {20¦30} year old (mythical:1.1) demon with {medium|long} {brown|black} hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy {office¦country¦castle} background, rule of thirds, composed\n"
+ "Negative Template: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}