import Foundation
let pattern = #"^([^:]+):|(?!^)(?<=\G)(?:\s)([^,]+)(?:,|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Prompt: professional digital [airbrush:gouache:0.6] art of 20 year old (mythical:1.1) demon with long black hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy country background, rule of thirds, composed
Negative prompt: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned
Template: professional digital [airbrush:gouache:0.6] art of {20¦30} year old (mythical:1.1) demon with {medium|long} {brown|black} hair, wearing ragged jacket and jeans, dynamic lighting, outstanding, masterpiece, cinematic, best, perfect, slightly blurry fantasy {office¦country¦castle} background, rule of thirds, composed
Negative Template: (child), (male), (mangled hands), (badly drawn hands),( badly drawn fingers), back turned
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)