import re
regex = re.compile(r".*(?=\Q-host1.host2.host3.com:80\E)")
test_str = "my-name-host1.host2.host3.com:80"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")