re = /.*(?=\Q-host1.host2.host3.com:80\E)/
str = 'my-name-host1.host2.host3.com:80'
# Print the match result
str.match(re) do |match|
puts match.to_s
end