import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<date>\\d{4}_?\\d{2}_?\\d{2})_(?<meeting_type>\\w{2,3})_((?<agenda>[a-z0-9]{1,3})_)?(?<description>.+)?\\.pdf$";
final String string = "20200225_RM_agenda.pdf\n"
+ "20200225_RM_2_memo.pdf\n"
+ "20200225_ss1_3c_presenTATION.pdf\n"
+ "20200225_CA_4d_SiGnEd.pdf\n"
+ "20200225_RM_5_Order1234.pdf\n"
+ "2020_02_25_EV_Notice.pdf";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}