#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)def[^(]*\((*SKIP)(*F)|\("
Local $sString = "def a(self)" & @CRLF & _
"def ab(self)" & @CRLF & _
"def abc(self)" & @CRLF & _
"def abcd(self)" & @CRLF & _
"" & @CRLF & _
"a(self)" & @CRLF & _
"ab(self)" & @CRLF & _
"abc(self)" & @CRLF & _
"abcd(self)" & @CRLF & _
"" & @CRLF & _
"It should not match lines with: " & @CRLF & _
"" & @CRLF & _
" anything def anything(thing) " & @CRLF & _
"" & @CRLF & _
"And only match lines as:" & @CRLF & _
"" & @CRLF & _
" anything anything(thing)" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")