$re = '/def[^(]*\((*SKIP)(*F)|\(/m';
$str = 'def a(self)
def ab(self)
def abc(self)
def abcd(self)
a(self)
ab(self)
abc(self)
abcd(self)
It should not match lines with:
anything def anything(thing)
And only match lines as:
anything anything(thing)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);