const regex = new RegExp('^(?P<mounting_type>Z)(?P<number_of_function>1)(?P<unit_type>S)(?P<unit_size>6)(?P<function_in_port>AB-P|B-A|T-P|A|B|C|D|E|F|P|T)(?P<cracking_pressure>05|15|30|50)(?P<sep_1>-)(?P<unit_series>4X)(?P<sep_2>/|=)(?P<seal_material>V|N|MT)(?P<surface_coating>J3|)(?P<pipe_port>/60|/62|)(?P<special_version>SO68|SO90|SO104|)(?P<additional_details>(.|[0-9])*)$
', 'gm')
const str = `Z1S6E05-4X/V
Z1S6E30-4X/V
Z1S6E50-4X/V
Z1S6F05-4X/V
Z1S6F30-4X/V
Z1S6F50-4X/V
Z1S6P05-4X/V
Z1S6P30-4X/V
Z1S6P50-4X/V
Z1S6T05-4X/V
Z1S6T30-4X/V
Z1S6T50-4X/V
Z1S6A05-4X/V
Z1S6A30-4X/V
Z1S6A50-4X/V
Z1S6B05-4X/V
Z1S6B30-4X/V
Z1S6B50-4X/V
Z1S6C05-4X/V
Z1S6C30-4X/V
Z1S6C50-4X/V
Z1S6D05-4X/V
Z1S6D30-4X/V
Z1S6D50-4X/V
Z1S6C05-4X/VSO119
Z1S6P05-4X/VSO104
Z1S6P05-4X/VSO68
Z1S6P05-4X/VSO90
Z1S6P30-4X/VSO104
Z1S6P30-4X/VSO68
Z1S6P30-4X/VSO90
Z1S6T05-4X=V
Z1S6P15-4X/V
Z1S6P05-4X/V/62
Z1S6T15-4X/V
Z1S6AB-P05-4X/V
Z1S6T30-4X/N
Z1S6P05-4X/N
Z1S6E15-4X/V
Z1S6F05-4X=V
Z1S6C05-4X/N
Z1S6C30-4X/VSO68
Z1S6C05-4X/VSO68
Z1S6A15-4X/V
Z1S6C15-4X/V
Z1S6D15-4X/V
Z1S6D05-4X/N
Z1S6D05-4X=V
Z1S6B15-4X/V
Z1S6F15-4X/V
Z1S6T05-4X/N
Z1S6T15-4X/VSO68
Z1S6A15-4X/V/62SO68
Z1S6E05-4X/N
Z1S6T05-4X/VSO90
Z1S6T05-4X/VSO68
Z1S6P30-4X/N
Z1S6F50-4X/VJ3
Z1S6B05-4X/N
Z1S6F05-4X/N
Z1S6T50-4X/N
Z1S6C15-4X/N
Z1S6D15-4X=V
Z1S6D30-4X/N
Z1S6C05-4X/NSO68
Z1S6P05-4X/MTSO68
Z1S6D05-4X/VJ3
Z1S6T50-4X=V
Z1S6A05-4X=V
Z1S6B15-4X/N
Z1S6E15-4X/N
Z1S6D30-4X=V
Z1S6P15-4X/VSO104
Z1S6T15-4X/N
Z1S6T30-4X/VSO90
Z1S6A15-4X/VJ3
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}