use strict;
my $str = 'Z1S6E05-4X/V
Z1S6E30-4X/V
Z1S6E50-4X/V
Z1S6F05-4X/V
Z1S6F30-4X/V
Z1S6F50-4X/V
Z1S6P05-4X/V
Z1S6P30-4X/V
Z1S6P50-4X/V
Z1S6T05-4X/V
Z1S6T30-4X/V
Z1S6T50-4X/V
Z1S6A05-4X/V
Z1S6A30-4X/V
Z1S6A50-4X/V
Z1S6B05-4X/V
Z1S6B30-4X/V
Z1S6B50-4X/V
Z1S6C05-4X/V
Z1S6C30-4X/V
Z1S6C50-4X/V
Z1S6D05-4X/V
Z1S6D30-4X/V
Z1S6D50-4X/V
Z1S6C05-4X/VSO119
Z1S6P05-4X/VSO104
Z1S6P05-4X/VSO68
Z1S6P05-4X/VSO90
Z1S6P30-4X/VSO104
Z1S6P30-4X/VSO68
Z1S6P30-4X/VSO90
Z1S6T05-4X=V
Z1S6P15-4X/V
Z1S6P05-4X/V/62
Z1S6T15-4X/V
Z1S6AB-P05-4X/V
Z1S6T30-4X/N
Z1S6P05-4X/N
Z1S6E15-4X/V
Z1S6F05-4X=V
Z1S6C05-4X/N
Z1S6C30-4X/VSO68
Z1S6C05-4X/VSO68
Z1S6A15-4X/V
Z1S6C15-4X/V
Z1S6D15-4X/V
Z1S6D05-4X/N
Z1S6D05-4X=V
Z1S6B15-4X/V
Z1S6F15-4X/V
Z1S6T05-4X/N
Z1S6T15-4X/VSO68
Z1S6A15-4X/V/62SO68
Z1S6E05-4X/N
Z1S6T05-4X/VSO90
Z1S6T05-4X/VSO68
Z1S6P30-4X/N
Z1S6F50-4X/VJ3
Z1S6B05-4X/N
Z1S6F05-4X/N
Z1S6T50-4X/N
Z1S6C15-4X/N
Z1S6D15-4X=V
Z1S6D30-4X/N
Z1S6C05-4X/NSO68
Z1S6P05-4X/MTSO68
Z1S6D05-4X/VJ3
Z1S6T50-4X=V
Z1S6A05-4X=V
Z1S6B15-4X/N
Z1S6E15-4X/N
Z1S6D30-4X=V
Z1S6P15-4X/VSO104
Z1S6T15-4X/N
Z1S6T30-4X/VSO90
Z1S6A15-4X/VJ3
';
my $regex = qr/^(?P<mounting_type>Z)(?P<number_of_function>1)(?P<unit_type>S)(?P<unit_size>6)(?P<function_in_port>AB-P|B-A|T-P|A|B|C|D|E|F|P|T)(?P<cracking_pressure>05|15|30|50)(?P<sep_1>-)(?P<unit_series>4X)(?P<sep_2>/|=)(?P<seal_material>V|N|MT)(?P<surface_coating>J3|)(?P<pipe_port>/60|/62|)(?P<special_version>SO68|SO90|SO104|)(?P<additional_details>(.|[0-9])*)$
/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}