package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b\d+\)[^;]*- ex\b`)
var str = `1) drug A; 2) drug B; 3) drug C - ex; 4) drug D`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}