const regex = /\b\d+\)[^;]*- ex\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d+\\)[^;]*- ex\\b', 'gm')
const str = `1) drug A; 2) drug B; 3) drug C - ex; 4) drug D`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}