$re = '/([a-z]{5,8}_\d{1,2})\.jpg/m';
$str = 'aaaaa_11.jpg
aaaaa_11.jpeg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);