#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^([A-Za-z]*)(-)([0-9]*)(.+)$"
Local $sString = "pouy-78-1_viuelsov-boltespmer_1.pdf"
Local $sSubst = "\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)