#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\((?:[^()]++|(?1))*\))(*SKIP)(*FAIL)|;"
Local $sString = "abcd;ghi;dfsF(adffg;adfsasdf);dfg;(asd;fdsg);ag" & @CRLF & _
"zvc;dfasdf;asdga;asd(asd;hsfd)" & @CRLF & _
"adsg;(asdg;ASF;DFG;ASDF;);sdafdf" & @CRLF & _
"asagf;(fafgf;sadg;sdag;a;gddfg;fd)gsfg;sdfa" & @CRLF & _
"" & @CRLF & _
"asagf;(fafgf(;sadg(;sdag;))a;gddfg;fd)gsfg;sdfa" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")