package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\((?:[^()]++|(?1))*\))(*SKIP)(*FAIL)|;`)
var str = `abcd;ghi;dfsF(adffg;adfsasdf);dfg;(asd;fdsg);ag
zvc;dfasdf;asdga;asd(asd;hsfd)
adsg;(asdg;ASF;DFG;ASDF;);sdafdf
asagf;(fafgf;sadg;sdag;a;gddfg;fd)gsfg;sdfa
asagf;(fafgf(;sadg(;sdag;))a;gddfg;fd)gsfg;sdfa
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}