$re = '/[@][\W]/m';
$str = 'DECLARE @showBrand@ VARCHAR(MAX) = \'1\';
DECLARE @showBrandImage@ VARCHAR(MAX) = \'[]\';
DECLARE @ShowBrandLink@ VARCHAR(MAX) = \'[]\';
DECLARE @ShowbreakLineAfterSize@ VARCHAR(MAX) = \'[]\';
DECLARE @showbreaklineAfterStock@ VARCHAR(MAX) = \'[]\';
DECLARE @showBuyBtn@ VARCHAR(MAX) = \'1\';';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);