re = /[@][\W]/m
str = 'DECLARE @showBrand@ VARCHAR(MAX) = \'1\';
DECLARE @showBrandImage@ VARCHAR(MAX) = \'[]\';
DECLARE @ShowBrandLink@ VARCHAR(MAX) = \'[]\';
DECLARE @ShowbreakLineAfterSize@ VARCHAR(MAX) = \'[]\';
DECLARE @showbreaklineAfterStock@ VARCHAR(MAX) = \'[]\';
DECLARE @showBuyBtn@ VARCHAR(MAX) = \'1\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end